Follow

Seems the Android 10 requirement is only if you want to use your DS4 wirelessly, which isn't a huge issue.

Sign in to participate in the conversation
Chitter

Chitter is a social network fostering a friendly, inclusive, and incredibly soft community.